Pokemon save corruption issues (work-around in thread)

Ask questions about DraStic or discuss compatibility issues here.
Posts: 5
Joined: Sun Jun 29, 2014 2:36 am

Re: Pokemon save corruption issues (work-around in thread)

Post by nightlyshade » Sun Jun 29, 2014 6:13 am

Pokemon Heartgold works perfectly for me! i even saved my game before i went into a cave.... just in case. And everything worked normally! besides, the dark cave was dark and i could only see around my character... and, around the border of the screen. Small glitch but definitely playable! and i was able to exit the cave as well :). Must be your rom...i downloaded the version 2 rom since i dont know how to extract the rom off my ds game :S and by version 2 i mean, the rom was patched and given v2 in part of its name to signify that the glitches in v1 were solved. You might have the v1 rom... if so i would try to get the v2... it works perfectly so far
In the latest beta update it fixes this issue! the cave is now completely dark! no cheating XD i can only see directly around my character....

Maximilian Otto
Posts: 1
Joined: Mon Aug 04, 2014 3:37 pm

Re: Pokemon save corruption issues (work-around in thread)

Post by Maximilian Otto » Mon Aug 04, 2014 4:19 pm

Hi I was playing pokemon Pokemon Soul Silver when the game crashed. When I restarted drastic ds it didn't show the game anymore. Other games weren't showed ether if anyone could help me please quote.


Posts: 2
Joined: Tue Sep 30, 2014 10:16 pm

Re: Pokemon save corruption issues (work-around in thread)

Post by a_mailloux » Wed Oct 01, 2014 10:36 am

My pokemon black ingame save somehow got turned back to a in game save from earlier in the day. Help?

Derek Dover
Posts: 1
Joined: Tue Dec 16, 2014 3:56 pm

Re: Pokemon save corruption issues (work-around in thread)

Post by Derek Dover » Tue Dec 16, 2014 4:19 pm

Hi, my savestate for Pokémon Platinum isn't loading and upon start up; makes a few music tones and then re-attempts to load again. I saved just as I was entering the door to "Hearthome City Gym" and saved as the screen went black. I understand how this could disrupt the game due to the game loading the next area but an hour beforehand; there was a message explaining that I hadn't opened the Zip code and that memory was running low but this wasn't a problem on my Pokémon Heartgold ROM. I tried: Deleting the ROM while keeping the savestate, deleting other things on my phone to make more space and unzipping the game's Zip file. None of these helped and I'm out of options as the last savestate backip was 2 days ago and resuming would result in many hours being wasted. Do you have a solution to this problem?


Posts: 2
Joined: Mon Mar 09, 2015 7:24 pm

Re: Pokemon save corruption issues (work-around in thread)

Post by wantedd » Sat Mar 14, 2015 11:07 am

Guys i play pokemon sacred gold and everything was fine until the game freezes in the safarin zone. Whenever i quit and restart its still a black window and i cant do anything. It happened after a 2v2 match when i wanted to save the game. I rly dont want to lose my progress, so ppls let me know if you have a solution.

Posts: 1
Joined: Wed Apr 29, 2015 4:11 am

Re: Pokemon save corruption issues (work-around in thread)

Post by morizig » Wed Apr 29, 2015 4:52 am

Hi everyone,
Sorry to dig this up too
But i'm having the same problem as the other guy.
Followed every step like 10 times already still no luck.

This is my save state: https://www.dropbox.com/s/hmn9doi1xs9hi ... 1.dss?dl=0

I hope you kind sirs can help me out :)

Posts: 2
Joined: Sun May 03, 2015 6:36 am

Re: Pokemon save corruption issues (work-around in thread)

Post by petra » Sun May 03, 2015 6:42 am

Hi all, sorry for digging up an old thread but I'm really stuck and I already did every possible solution here in this forum. I bought Drastic from google store and I'm also having the same problem as "Flaw". Can anyone help me please?

Posts: 2
Joined: Thu Jul 02, 2015 10:54 am

Re: Pokemon save corruption issues (work-around in thread)

Post by baqqins » Thu Jul 02, 2015 11:28 am

Hello! Not sure if this is the right topic :?
but I have a problem with Soul Silver....
I bought the DraStic app from google store regularly, I've heard about an update but I've installed it max 2 months ago, so I think I already have the updated ver.?
Anyways, I downloaded pkmn Soul SIlver and recently Black 2.
But recently happened something to my soul silver! It worked almost well (with some trouble but i'll explain later) until i got all the 16 badges and reached the entrance of mt. Silver. And now I'm stuck there with Baoba calling me. In fact, every time i open it, i can just do a few steps and:
-if i go down it freezes in a grass patch
-if i enter the cave it turns black (music going on)
-if i move in the grass i encounter a lv42 ponyta and it freezes with the trainer sprite throwing the ball (music going on)
-if i try to open the bag i can view my items but if i try to use one it goes black after closing the bag
-any other thing in menu (pokemon squad, pokegear, save, options, pokedex, it turns black.
I always use the quick save (barely use the in-game save)and i often used some cheats.(i always go and disable cheats before doing the save) (not sure if it's because of them or if i deleted something accientally! I'll explain later, now the cheats: )
I had some previous trouble with cheats that still persist, but never bothered me anyways:
1. the daycare has a ditto and an eevee who continue making eggs despite i disabled either the obtain egg and the quick hatch (an egg will pop up after a few steps (even if i dont press any button) and i can't take the pkmns down because the grandma tells me that her hsband is looking for me=another egg)
2. suicune wasn't showing in the last route (before the final encounter) and was nowhere (checked all the places)

Yesterday I used some new cheats: max pokeballs, 100% catch and rebattle pkmn. I used it to battle suicune (it appeared in the last place where it should be and i catched it with the 100%catch cheat on)
then i continued the game, obtained the badges left and arrived to mt.silver.
There I saved and then I connected my phone (Samsung galaxy Ace Style SM-GT310) to transfer some other data. I went in the Soul Silver folder and noticed i had either the zipped and the unzipped files. I tried to move the zipped file in the folder, but while it was moving, i changed my mind and clicked on "undo". Now the zipped file isn't in the folder and isn't out of it! It disappeared?
The fact is, after this when i try to play the game it does the thing i wrote at the beginning.
Also, the collar of my Typhlosion glitches with a tree, but don't know if this is normal, i just didn't notice it before!
And, i have 5 or 6 previous savestates, but they freeze too after a few steps!
Help, I don't know what to do!
Thanks to whoever will help!

Posts: 1
Joined: Wed Aug 05, 2015 3:49 pm

Re: Pokemon save corruption issues (work-around in thread)

Post by Head0r » Wed Aug 05, 2015 3:56 pm

Hey Guys I am using a Samsung Note 3 and the newest DraStic Version.
I am playing a Pokemon Black 2 Rom.
One time i started the Game(Loaded a quicksave) the game introduction startet (as if i would start a new game).
However, I then loaded my latest Save-File. It loads but after about 1 second the game (including sound) freezes.

There is another file working but it is miiiiles away from my actual progress ingame.
is ther a possibility to make the Save-file working again?
I do not have any ingame-savefile (I did not safe in the Pokemon Game-Menue)

I hope one of you does now what to do.
i read something about files with an error "...corrupt file ..." or something like that. but i dont get an error message like that. also its not the octobre Problem i read about.



Posts: 1
Joined: Fri Jan 29, 2016 9:01 am

Re: Pokemon save corruption issues (work-around in thread)

Post by aadamkoo » Fri Jan 29, 2016 9:16 am

Nice to meet you all.. i have just purchased your emulator and started playing pokemon platinum... Everything works fine, smoothly, emulator save works ok but whn I save ingame and restart the emulator to load the game from the ingame ave it, the screen fades to white for like a second and then it restarts the game again.. As I said I still can load the game from emulator saves but cant from ingame dont know why I even tryed the method up above to delete the backup made a fresh start 0:00 saved and when I wanted to load from the game the same thing happened.. It just restarted the rom. Im not far into the game like 2hrs but even fresh start wont work so I ask you kindly forr help. If I remember ypu need to launch from the ingame save once you beat elite 4 right? Thanks for suggestions in forward.

Post Reply